chiark / gitweb /
[PATCH] 009_bk makefile changes.
[elogind.git] / udev.spec
index bd455ef2b1c99b7b2771018fa2ab6a0ee3d0170b..f8bde13171bb512c0fd17385188a5e782e9b3a9f 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -1,6 +1,6 @@
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 008_bk
+Version: 009_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -23,6 +23,14 @@ make CC="gcc $RPM_OPT_FLAGS"
 %install
 make DESTDIR=$RPM_BUILD_ROOT install
 
+%post
+/sbin/chkconfig --add udev
+
+%postun
+if [ $1 = 0 ]; then
+       /sbin/chkconfig --del udev
+fi
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -40,6 +48,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(0644,root,root) %{_mandir}/man8/udev.8*
 
 %changelog
+* Tue Dec 16 2003 Robert Love <rml@ximian.com>
+- install the initscript and run chkconfig on it
+
 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
 - changes due to config file name changes