chiark / gitweb /
ipif: Deprecate udptunnel.
[userv-utils.git] / debian / rules
index b7353f3718106fef500e59e0a335b2468af6398a..dbe4360abbd7463500042331a984bf25333ef221 100755 (executable)
@@ -1,5 +1,24 @@
 #!/usr/bin/make -f
 
+# Copyright 1996-2013 Ian Jackson <ijackson@chiark.greenend.org.uk>
+# Copyright 1998 David Damerell <damerell@chiark.greenend.org.uk>
+# Copyright 1999,2003
+#    Chancellor Masters and Scholars of the University of Cambridge
+# Copyright 2010 Tony Finch <fanf@dotat.at>
+#
+# This is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with userv-utils; if not, see http://www.gnu.org/licenses/.
+
 subdirs_build= ipif www-cgi git-daemon
 subdirs_nobuild=dyndns groupmanage misc
 package=       userv-utils
@@ -13,7 +32,9 @@ t=    $d/tmp
 
 build:
        $(checkdir)
-       set -e; for s in $(subdirs_build); do $(MAKE) -C $$s all; done
+       set -e; for s in $(subdirs_build); do \
+               $(MAKE) -C $$s all depr=disable; \
+       done
        touch build
 
 clean:
@@ -36,6 +57,7 @@ binary-prep:
                        etcdir=$t/userv-$$s/etc \
                        vardir=$t/userv-$$s/var \
                        gituser=root; \
+                       depr=disable; \
        done
        #
        mv debian/tmp/userv-www-cgi debian/tmp/userv-cgi