chiark / gitweb /
Merge tag 'topgit-0.8' of git://repo.or.cz/topgit
[topgit.git] / debian / tg2quilt.mk
index 2ff9bc9a754f7cc051143ef3952cecdc8caf7534..c1cc95a812ad9ad1c287ee5931dc9ffb1b9e7d3e 100644 (file)
@@ -68,11 +68,16 @@ else
 
 # We are in a TopGit branch, so let the fun begin.
 
-ifdef (PATCHES_DIR)
-       @echo 'W: The $PATCHES_DIR variable is deprecated, please use $QUILT_PATCH_DIR instead' >&2
+ifdef PATCHES_DIR
+       DUMMY := $(warning W: The $$PATCHES_DIR variable is deprecated, please use $$QUILT_PATCH_DIR instead.)
+       DUMMY := $(warning W: Sleeping for 10 seconds so you can read this!)
+       DUMMY := $(shell sleep 10)
        QUILT_PATCH_DIR := $(PATCHES_DIR)
 endif
 
+QUILT_PATCH_DIR ?= debian/patches
+QUILT_STAMPFN ?= patch
+
 # Hook tg-export into quilt's make(1) snippet such that it gets executed
 # before quilt patches or unpatches.
 $(QUILT_STAMPFN): tg-export
@@ -120,7 +125,7 @@ else
         # remove the series file
        test -f $(QUILT_PATCH_DIR)/series && rm $(QUILT_PATCH_DIR)/series || :
        # try to remove directories
-       find $(QUILT_PATCH_DIR) -type d | tac | xargs rmdir 2>/dev/null || :
+       find $(QUILT_PATCH_DIR) -depth -type d -empty -execdir rmdir {} +
        # fail if the directory could not be removed and still exists
        @test ! -d $(QUILT_PATCH_DIR) || { \
          echo "E: $(QUILT_PATCH_DIR) contains non-TopGit-generated files:" >&2; \