chiark / gitweb /
control: depend on git | git-core
[topgit.git] / debian / tg2quilt.mk
index f4ca0dbf3078a36d467a2779a3d3b91ff4f0af1e..744b853a4e41a156748e41e6135851c38641eabc 100644 (file)
@@ -122,13 +122,14 @@ else
   tg-rmdir: __TG_FILES := $(shell find $(QUILT_PATCH_DIR) -type f -a -not -path \*/series \
                                     | xargs grep -l '^tg:')
   tg-rmdir:
-       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt pop -a
+       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt pop -a 2>/dev/null || :
        @if quilt applied >/dev/null 2>&1; then \
          echo "E: there are applied quilt patches." >&2; \
          echo "E: please unapply (pop) all patches and try again." >&2; \
          false; \
        fi
-       @if git status -am. >/dev/null; then \
+       @git update-index -q --ignore-submodules --refresh
+       @if git diff-index --quiet --cached HEAD --ignore-submodules -- > /dev/null || git diff-files --quiet --ignore-submodules > /dev/null; then \
          echo "E: there are uncommitted changes in the working directory." >&2; \
          echo "E: please commit or revert all changes." >&2; \
          false; \