chiark / gitweb /
simplify removal of files in tg-rmdir
[topgit.git] / debian / tg2quilt.mk
index c1cc95a812ad9ad1c287ee5931dc9ffb1b9e7d3e..671dc04a8b6f6c5d1b0a089405f5719ad4824aa5 100644 (file)
@@ -121,9 +121,9 @@ else
                                     | xargs grep -l '^tg:')
   tg-rmdir:
        # remove all files whose contents matches /^tg:/
-       test -n "$(__TG_FILES)" && rm $(__TG_FILES) || :
-        # remove the series file
-       test -f $(QUILT_PATCH_DIR)/series && rm $(QUILT_PATCH_DIR)/series || :
+       rm -f $(__TG_FILES)
+       # remove the series file
+       rm -f $(QUILT_PATCH_DIR)/series
        # try to remove directories
        find $(QUILT_PATCH_DIR) -depth -type d -empty -execdir rmdir {} +
        # fail if the directory could not be removed and still exists