chiark / gitweb /
simplify removal of files in tg-rmdir
[topgit.git] / debian / tg2quilt.mk
index 4ec27e27e12028fcd1a14aba4e951b0659e5b2fb..671dc04a8b6f6c5d1b0a089405f5719ad4824aa5 100644 (file)
@@ -75,6 +75,9 @@ ifdef PATCHES_DIR
        QUILT_PATCH_DIR := $(PATCHES_DIR)
 endif
 
        QUILT_PATCH_DIR := $(PATCHES_DIR)
 endif
 
+QUILT_PATCH_DIR ?= debian/patches
+QUILT_STAMPFN ?= patch
+
 # Hook tg-export into quilt's make(1) snippet such that it gets executed
 # before quilt patches or unpatches.
 $(QUILT_STAMPFN): tg-export
 # Hook tg-export into quilt's make(1) snippet such that it gets executed
 # before quilt patches or unpatches.
 $(QUILT_STAMPFN): tg-export
@@ -118,9 +121,9 @@ else
                                     | xargs grep -l '^tg:')
   tg-rmdir:
        # remove all files whose contents matches /^tg:/
                                     | xargs grep -l '^tg:')
   tg-rmdir:
        # remove all files whose contents matches /^tg:/
-       test -n "$(__TG_FILES)" && rm $(__TG_FILES) || :
-        # remove the series file
-       test -f $(QUILT_PATCH_DIR)/series && rm $(QUILT_PATCH_DIR)/series || :
+       rm -f $(__TG_FILES)
+       # remove the series file
+       rm -f $(QUILT_PATCH_DIR)/series
        # try to remove directories
        find $(QUILT_PATCH_DIR) -depth -type d -empty -execdir rmdir {} +
        # fail if the directory could not be removed and still exists
        # try to remove directories
        find $(QUILT_PATCH_DIR) -depth -type d -empty -execdir rmdir {} +
        # fail if the directory could not be removed and still exists