chiark / gitweb /
tg2quilt.mk: don't call git-status with git-commit options
[topgit.git] / debian / tg2quilt.mk
index f83caa6701f95fb6b2a540c24e53ebb877b78a76..744b853a4e41a156748e41e6135851c38641eabc 100644 (file)
@@ -128,7 +128,8 @@ else
          echo "E: please unapply (pop) all patches and try again." >&2; \
          false; \
        fi
-       @if git status -am. >/dev/null; then \
+       @git update-index -q --ignore-submodules --refresh
+       @if git diff-index --quiet --cached HEAD --ignore-submodules -- > /dev/null || git diff-files --quiet --ignore-submodules > /dev/null; then \
          echo "E: there are uncommitted changes in the working directory." >&2; \
          echo "E: please commit or revert all changes." >&2; \
          false; \