chiark / gitweb /
Commit 2.4.5-5 as unpacked
[innduct.git] / debian / inn2.preinst
1 #!/bin/sh -e
2
3 if [ "$2" ] && dpkg --compare-versions $2 gt 2.0.0 \
4         && dpkg --compare-versions $2 lt 2.3.0; then
5   echo "Some configuration files have changed in INN 2.4 and will need to"
6   echo "be adjusted, most notably nnrp.access has mutated into readers.conf."
7   echo "Also, note that you may need to rebuild the history database."
8   echo "For more information, read the /usr/share/doc/inn2/NEWS.gz file."
9 fi
10
11 if [ "$2" ] && dpkg --compare-versions $2 eq 2.3.0-1; then
12   echo 'Upgrade from 2.3.0-1 to >= 2.3.999+20030125-4 is not supported.'
13   echo 'Aborting inn upgrade.'
14   exit 1
15 fi
16
17 if [ "$2" ] && dpkg --compare-versions $2 lt 2.3.1-2; then
18   # remove any remaining symlinks under /usr/lib/news/bin/filter, then remove
19   # the directory if it's empty
20   if [ -d /usr/lib/news/bin/filter ]; then
21     find /usr/lib/news/bin/filter -type l -exec rm {} \;
22     rmdir /usr/lib/news/bin/filter 2> /dev/null || true
23   fi
24 fi
25
26 #DEBHELPER#
27
28 exit 0