chiark / gitweb /
config: sort out directory handling
[hippotat.git] / debian / rules
index d087b53263e505b576982cc0225a7f70be8354e5..d23107cbe2eaca54e812bbbdaacb6cb8e5853cd2 100755 (executable)
@@ -1,6 +1,17 @@
 #!/usr/bin/make -f
 
+SHELL=/bin/bash
+
 export PYBUILD_INSTALL_DIR=/usr/share/hippotat/python3
 
 %:
        dh $@ --with python3 --buildsystem=pybuild
+
+i=debian/hippotat
+
+debian/copyright: COPYING AGPLv3+CAFv2
+       cat $^ >$@.tmp && mv -f $@.tmp $@
+
+override_dh_compress:
+       find $i/usr/{bin,sbin} -type f | xargs ./subst-sys-path
+       dh_compress