chiark / gitweb /
rules: introduce $i
[hippotat.git] / debian / rules
index 97072131a49b20eaee11fa4ebc8f4c5c6ad8c693..d23107cbe2eaca54e812bbbdaacb6cb8e5853cd2 100755 (executable)
@@ -1,9 +1,17 @@
 #!/usr/bin/make -f
 
+SHELL=/bin/bash
+
 export PYBUILD_INSTALL_DIR=/usr/share/hippotat/python3
 
 %:
        dh $@ --with python3 --buildsystem=pybuild
 
+i=debian/hippotat
+
 debian/copyright: COPYING AGPLv3+CAFv2
        cat $^ >$@.tmp && mv -f $@.tmp $@
+
+override_dh_compress:
+       find $i/usr/{bin,sbin} -type f | xargs ./subst-sys-path
+       dh_compress