chiark / gitweb /
ResponseConsumer: break out connectionLostOK into superclass
[hippotat.git] / debian / rules
index 97072131a49b20eaee11fa4ebc8f4c5c6ad8c693..419c3b74a5bd75490f58a2e68d98f8cd8218fc1f 100755 (executable)
@@ -1,9 +1,25 @@
 #!/usr/bin/make -f
 
+SHELL=/bin/bash
+
 export PYBUILD_INSTALL_DIR=/usr/share/hippotat/python3
 
 %:
        dh $@ --with python3 --buildsystem=pybuild
 
+i=debian/hippotat
+
 debian/copyright: COPYING AGPLv3+CAFv2
        cat $^ >$@.tmp && mv -f $@.tmp $@
+
+override_dh_python3:
+       dh_python3 -O--buildsystem=pybuild
+       dh_installdirs /usr/sbin
+       mv $i/usr/{bin,sbin}/hippotatd
+
+override_dh_installinit:
+       dh_installinit --name=hippotatd
+
+override_dh_compress:
+       find $i/usr/{bin,sbin} -type f | xargs ./subst-sys-path
+       dh_compress