chiark / gitweb /
ResponseConsumer: break out connectionLostOK into superclass
[hippotat.git] / debian / rules
index 17bbf5e9232348187941c673eea61a2a866fe563..419c3b74a5bd75490f58a2e68d98f8cd8218fc1f 100755 (executable)
@@ -7,9 +7,19 @@ export PYBUILD_INSTALL_DIR=/usr/share/hippotat/python3
 %:
        dh $@ --with python3 --buildsystem=pybuild
 
+i=debian/hippotat
+
 debian/copyright: COPYING AGPLv3+CAFv2
        cat $^ >$@.tmp && mv -f $@.tmp $@
 
+override_dh_python3:
+       dh_python3 -O--buildsystem=pybuild
+       dh_installdirs /usr/sbin
+       mv $i/usr/{bin,sbin}/hippotatd
+
+override_dh_installinit:
+       dh_installinit --name=hippotatd
+
 override_dh_compress:
-       find debian/hippotat/usr/{bin,sbin} -type f | xargs ./subst-sys-path
+       find $i/usr/{bin,sbin} -type f | xargs ./subst-sys-path
        dh_compress