chiark / gitweb /
Fix up sys.path in scripts
[hippotat.git] / debian / rules
index 97072131a49b20eaee11fa4ebc8f4c5c6ad8c693..17bbf5e9232348187941c673eea61a2a866fe563 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 
+SHELL=/bin/bash
+
 export PYBUILD_INSTALL_DIR=/usr/share/hippotat/python3
 
 %:
@@ -7,3 +9,7 @@ export PYBUILD_INSTALL_DIR=/usr/share/hippotat/python3
 
 debian/copyright: COPYING AGPLv3+CAFv2
        cat $^ >$@.tmp && mv -f $@.tmp $@
+
+override_dh_compress:
+       find debian/hippotat/usr/{bin,sbin} -type f | xargs ./subst-sys-path
+       dh_compress