chiark / gitweb /
debian/changelog: finalise 4.5.0~iwj4
[chiark-utils.git] / debian / rules
index bee06b08f1d641db64db7c9c22f8365b62d888fb..ee7e2832a6b586d38ec297915d59dcc7d28fd0f0 100755 (executable)
@@ -13,29 +13,36 @@ cwd=        $(shell pwd)
 d=     $(cwd)/debian
 t=     $d/tmp
 
-build-arch:
-       $(checkdir)
-       set -e; for s in $(subdirs_build_arch); do $(MAKE) -C $$s all; done
-       touch build_arch
+makebuildargs := OPTIMISE= DEBUG= \
+ CMDLINE_CFLAGS="$(shell dpkg-buildflags --get CFLAGS)" \
+ CMDLINE_CPPFLAGS="$(shell dpkg-buildflags --get CPPFLAGS)" \
+ CMDLINE_LDFLAGS="$(shell dpkg-buildflags --get LDFLAGS)"
 
-build-indep:
+build:
+       $(checkdir)
+       set -e; for s in $(subdirs_build_arch); do \
+               $(MAKE) -C $$s all $(makebuildargs); \
+       done
+       touch build
 
-build: build-arch build-indep
+build-indep: build
+build-arch: build
 
 clean:
        $(checkdir)
        rm -f build
-       set -e; for s in $(subdirs_build); do \
+       set -e; for s in $(subdirs_build_arch); do \
                $(MAKE) -C $$s -i distclean || \
                $(MAKE) -C $$s -f Makefile.in distclean; \
        done
        rm -rf *~ debian/tmp debian/*~ debian/files* debian/substvars*
+       rm -rf debian/sv-* debian/*.debhelper.log
 
 binary-prep:
        $(checkdir)
        rm -rf debian/tmp*
        #
-       set -e; for s in $(subdirs_build) $(subdirs_nobuild); do \
+       set -e; for s in $(subdirs_build_arch) $(subdirs_nobuild); do \
                $(MAKE) -C $$s install install-docs install-examples \
                        prefix=$t/$$s/usr \
                        etcdir=$t/$$s/etc \
@@ -84,8 +91,7 @@ binary-prep:
                mv really.8 $t/chiark-really/usr/share/man/man8/
        rm      $t/chiark-utils-bin/usr/sbin/trivsoundd \
                $t/chiark-utils-bin/usr/share/man/man8/trivsoundd.8
-       rmdir   $t/chiark-utils-bin/usr/sbin \
-               $t/chiark-utils-bin/usr/share/man/man8
+       rmdir   $t/chiark-utils-bin/usr/sbin
        #
        gzip -9f $t/*/usr/share/man/man*/*
 
@@ -102,7 +108,8 @@ binary-one:
                cp debian/$p/$$f $t/$p/DEBIAN/$$f; \
                chmod u=rwX,go=rX $t/$p/DEBIAN/$$f; \
        done
-       dpkg-gencontrol -isp -p$p -P$t/$p -Tdebian/sv-$p
+       dh_link -p$p -Pdebian/tmp/$p
+       dpkg-gencontrol -p$p -P$t/$p -Tdebian/sv-$p
        chown -R root.root debian/tmp
        chmod -R g-ws debian/tmp
        debian/rules binary-hook-$p
@@ -122,8 +129,10 @@ binary-arch:       checkroot build binary-prep
                $t/chiark-really/usr/sbin/*
        set -e; for f in $t/chiark-utils-bin/usr/bin/*; do \
                case "$$f" in \
-               */xacpi-simple)         d=Suggests      ;; \
-               */watershed|*/summer)   d=Recommends    ;; \
+               */xbatmon-simple|*/xduplic-copier) \
+                                       d=Suggests      ;; \
+               */watershed|*/summer|*/cgi-fcgi-interp) \
+                                       d=Recommends    ;; \
                *)                      d=Depends       ;; \
                esac; \
                a="$$a -d$$d $$f"; \