chiark / gitweb /
cgi-fcgi-interp: correct the copyright header rubric.
[chiark-utils.git] / debian / rules
index b711bb1c1a5f12c74c2960926bbab8e095370466..ee7e2832a6b586d38ec297915d59dcc7d28fd0f0 100755 (executable)
@@ -91,8 +91,7 @@ binary-prep:
                mv really.8 $t/chiark-really/usr/share/man/man8/
        rm      $t/chiark-utils-bin/usr/sbin/trivsoundd \
                $t/chiark-utils-bin/usr/share/man/man8/trivsoundd.8
-       rmdir   $t/chiark-utils-bin/usr/sbin \
-               $t/chiark-utils-bin/usr/share/man/man8
+       rmdir   $t/chiark-utils-bin/usr/sbin
        #
        gzip -9f $t/*/usr/share/man/man*/*
 
@@ -110,7 +109,7 @@ binary-one:
                chmod u=rwX,go=rX $t/$p/DEBIAN/$$f; \
        done
        dh_link -p$p -Pdebian/tmp/$p
-       dpkg-gencontrol -isp -p$p -P$t/$p -Tdebian/sv-$p
+       dpkg-gencontrol -p$p -P$t/$p -Tdebian/sv-$p
        chown -R root.root debian/tmp
        chmod -R g-ws debian/tmp
        debian/rules binary-hook-$p
@@ -132,7 +131,8 @@ binary-arch:        checkroot build binary-prep
                case "$$f" in \
                */xbatmon-simple|*/xduplic-copier) \
                                        d=Suggests      ;; \
-               */watershed|*/summer)   d=Recommends    ;; \
+               */watershed|*/summer|*/cgi-fcgi-interp) \
+                                       d=Recommends    ;; \
                *)                      d=Depends       ;; \
                esac; \
                a="$$a -d$$d $$f"; \