chiark / gitweb /
@@ -1,3 +1,11 @@
[chiark-utils.git] / debian / rules
index 1733dcd8a95a92017d8938f044b088b1ca234610..e0c537338315b9d12b10782825543361f97f599a 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 
+SHELL=/bin/bash
+
 subdirs_build= cprogs
 subdirs_nobuild=backup sync-accounts scripts
 package=       chiark-utils
@@ -66,6 +68,9 @@ binary-prep:
                for m in *.1; do \
                        mv "$$m" backup-"$$m"; \
                done
+       cp \
+ $t/chiark-backup/usr/share/doc/chiark-backup/examples/chiark/settings.sh \
+ $t/chiark-backup/etc/chiark-backup/settings.sh
        #
        install -d $t/chiark-really/usr/sbin
        install -d $t/chiark-really/usr/share/man/man8
@@ -111,7 +116,8 @@ binary-arch:        checkroot build binary-prep
        dpkg-shlibdeps -Tdebian/sv-chiark-really \
                $t/chiark-really/usr/sbin/*
        dpkg-shlibdeps -Tdebian/sv-chiark-utils-bin \
-               $t/chiark-utils-bin/usr/bin/*
+               $t/chiark-utils-bin/usr/bin/[^x]* \
+               -dSuggests $t/chiark-utils-bin/usr/bin/x*
        set -e; for p in $(packages_arch); \
                do debian/rules binary-one p=$$p; done