chiark / gitweb /
fishdescriptor: build system (nugatory)
[chiark-utils.git] / debian / rules
index b711bb1c1a5f12c74c2960926bbab8e095370466..cc926b8e147e35939c3d63fd0ea32fb177448997 100755 (executable)
@@ -3,7 +3,7 @@
 SHELL=/bin/bash
 
 subdirs_build_arch=    cprogs
-subdirs_nobuild=backup sync-accounts scripts
+subdirs_nobuild=backup sync-accounts scripts fishdescriptor
 package=       chiark-utils
 packages_indep=        chiark-backup chiark-scripts
 packages_arch= chiark-rwbuffer chiark-really chiark-utils-bin
@@ -52,6 +52,7 @@ binary-prep:
        #
        mv $t/cprogs $t/chiark-utils-bin
        #
+       cp -a debian/tmp/fishdescriptor/* debian/tmp/scripts/.
        cp -a debian/tmp/sync-accounts/* debian/tmp/scripts/.
        rm -r debian/tmp/sync-accounts
        mv debian/tmp/scripts debian/tmp/chiark-scripts
@@ -63,7 +64,7 @@ binary-prep:
                        $t/$$p/usr/share/doc/$$p/; \
                ln -s changelog.gz \
                        $t/$$p/usr/share/doc/$$p/changelog.Debian.gz; \
-               gzip -9v $t/$$p/usr/share/doc/$$p/changelog; \
+               gzip -9vn $t/$$p/usr/share/doc/$$p/changelog; \
                done
        #
        install -d $t/chiark-rwbuffer/usr/bin
@@ -91,10 +92,9 @@ binary-prep:
                mv really.8 $t/chiark-really/usr/share/man/man8/
        rm      $t/chiark-utils-bin/usr/sbin/trivsoundd \
                $t/chiark-utils-bin/usr/share/man/man8/trivsoundd.8
-       rmdir   $t/chiark-utils-bin/usr/sbin \
-               $t/chiark-utils-bin/usr/share/man/man8
+       rmdir   $t/chiark-utils-bin/usr/sbin
        #
-       gzip -9f $t/*/usr/share/man/man*/*
+       gzip -9fn $t/*/usr/share/man/man*/*
 
 binary-hook-chiark-backup:
 binary-hook-chiark-rwbuffer:
@@ -110,7 +110,7 @@ binary-one:
                chmod u=rwX,go=rX $t/$p/DEBIAN/$$f; \
        done
        dh_link -p$p -Pdebian/tmp/$p
-       dpkg-gencontrol -isp -p$p -P$t/$p -Tdebian/sv-$p
+       dpkg-gencontrol -p$p -P$t/$p -Tdebian/sv-$p
        chown -R root.root debian/tmp
        chmod -R g-ws debian/tmp
        debian/rules binary-hook-$p
@@ -132,18 +132,13 @@ binary-arch:      checkroot build binary-prep
                case "$$f" in \
                */xbatmon-simple|*/xduplic-copier) \
                                        d=Suggests      ;; \
-               */watershed|*/summer)   d=Recommends    ;; \
+               */watershed|*/summer|*/cgi-fcgi-interp) \
+                                       d=Recommends    ;; \
                *)                      d=Depends       ;; \
                esac; \
                a="$$a -d$$d $$f"; \
            done; set -x; \
            dpkg-shlibdeps -Tdebian/sv-chiark-utils-bin $$a
-       perl -i~ -pe '                                          '\
-        -e'    next unless m/^shlibs:/;                        '\
-        -e'    s/$$/,/; s/=/=, /;                              '\
-        -e'    s/, libgmp3(?:c2)?,/, libgmp3 | libgmp3c2,/;    '\
-        -e'    s/=, /=/; s/,$$//;                              '\
-                       debian/sv-*[!~]
        set -e; for p in $(packages_arch); \
                do debian/rules binary-one p=$$p; done