chiark / gitweb /
dummy targets, sorry
[chiark-utils.git] / debian / rules
index 71c4f17f3bc6bb6d36269b001c879ce72cbe2566..bf733424c131944f2a3c35b303d2928eec118fe1 100755 (executable)
@@ -2,7 +2,7 @@
 
 SHELL=/bin/bash
 
-subdirs_build= cprogs
+subdirs_build_arch=    cprogs
 subdirs_nobuild=backup sync-accounts scripts
 package=       chiark-utils
 packages_indep=        chiark-backup chiark-scripts
@@ -15,9 +15,12 @@ t=   $d/tmp
 
 build:
        $(checkdir)
-       set -e; for s in $(subdirs_build); do $(MAKE) -C $$s all; done
+       set -e; for s in $(subdirs_build_arch); do $(MAKE) -C $$s all; done
        touch build
 
+build-indep: build
+build-arch: build
+
 clean:
        $(checkdir)
        rm -f build
@@ -76,7 +79,6 @@ binary-prep:
        install -d $t/chiark-really/usr/share/man/man8
        cd $t/chiark-utils-bin/usr/sbin && \
                mv really $t/chiark-really/usr/sbin/
-       strip --strip-unneeded --remove-section .note --remove-section .comment $t/chiark-really/usr/sbin/really
        cd $t/chiark-utils-bin/usr/share/man/man8 && \
                mv really.8 $t/chiark-really/usr/share/man/man8/
        rm      $t/chiark-utils-bin/usr/sbin/trivsoundd \
@@ -111,6 +113,8 @@ binary-indep:       checkroot build binary-prep
 
 binary-arch:   checkroot build binary-prep
        $(checkdir)
+       set -ex; for p in chiark-really chiark-utils-bin chiark-rwbuffer; do \
+               dh_strip -p$$p -Pdebian/tmp/$$p; done
        dpkg-shlibdeps -Tdebian/sv-chiark-rwbuffer \
                $t/chiark-rwbuffer/usr/bin/*
        dpkg-shlibdeps -Tdebian/sv-chiark-really \