chiark / gitweb /
debian/rules: use dpkg-buildflags and pass to Makefile.
[chiark-utils.git] / debian / rules
index d1ec8159e94953606bd694d5de08dc8a3925b1e5..b711bb1c1a5f12c74c2960926bbab8e095370466 100755 (executable)
@@ -13,9 +13,16 @@ cwd= $(shell pwd)
 d=     $(cwd)/debian
 t=     $d/tmp
 
+makebuildargs := OPTIMISE= DEBUG= \
+ CMDLINE_CFLAGS="$(shell dpkg-buildflags --get CFLAGS)" \
+ CMDLINE_CPPFLAGS="$(shell dpkg-buildflags --get CPPFLAGS)" \
+ CMDLINE_LDFLAGS="$(shell dpkg-buildflags --get LDFLAGS)"
+
 build:
        $(checkdir)
-       set -e; for s in $(subdirs_build_arch); do $(MAKE) -C $$s all; done
+       set -e; for s in $(subdirs_build_arch); do \
+               $(MAKE) -C $$s all $(makebuildargs); \
+       done
        touch build
 
 build-indep: build