chiark / gitweb /
@@ -4,8 +4,9 @@
[chiark-utils.git] / debian / rules
index 13d0680e828b8d6b9d8378c5b1bf058cdfee7a7d..86fb5b4b4edb2469ea04b01524e664b315b4418f 100755 (executable)
@@ -60,11 +60,21 @@ binary-prep:
        cd $t/chiark-utils-bin/usr/share/man/man1 && \
                mv readbuffer.1 writebuffer.1 $t/chiark-rwbuffer/usr/share/man/man1/
        #
+       install -d $t/chiark-backup/usr/share/man/man1
+       cp backup/man/*.1 $t/chiark-backup/usr/share/man/man1/
+       cd $t/chiark-backup/usr/share/man/man1 && \
+               for m in *.1; do \
+                       mv "$$m" backup-"$$m"; \
+               done
+       cp \
+ $t/chiark-backup/usr/share/doc/chiark-backup/examples/chiark/settings.sh \
+ $t/chiark-backup/etc/chiark-backup/settings.sh
+       #
        install -d $t/chiark-really/usr/sbin
        install -d $t/chiark-really/usr/share/man/man8
        cd $t/chiark-utils-bin/usr/sbin && \
                mv really $t/chiark-really/usr/sbin/
-       strip --strip-unneeded $t/chiark-really/usr/sbin/really
+       strip --strip-unneeded --remove-section .note --remove-section .comment $t/chiark-really/usr/sbin/really
        cd $t/chiark-utils-bin/usr/share/man/man8 && \
                mv really.8 $t/chiark-really/usr/share/man/man8/
        rm      $t/chiark-utils-bin/usr/sbin/trivsoundd \
@@ -87,7 +97,7 @@ binary-one:
                cp debian/$p/$$f $t/$p/DEBIAN/$$f; \
                chmod u=rwX,go=rX $t/$p/DEBIAN/$$f; \
        done
-       dpkg-gencontrol -p$p -P$t/$p -Tdebian/sv-$p
+       dpkg-gencontrol -isp -p$p -P$t/$p -Tdebian/sv-$p
        chown -R root.root debian/tmp
        chmod -R g-ws debian/tmp
        debian/rules binary-hook-$p
@@ -104,7 +114,8 @@ binary-arch:        checkroot build binary-prep
        dpkg-shlibdeps -Tdebian/sv-chiark-really \
                $t/chiark-really/usr/sbin/*
        dpkg-shlibdeps -Tdebian/sv-chiark-utils-bin \
-               $t/chiark-utils-bin/usr/bin/*
+               $t/chiark-utils-bin/usr/bin/[^x]* \
+               -dSuggests $t/chiark-utils-bin/usr/bin/x*
        set -e; for p in $(packages_arch); \
                do debian/rules binary-one p=$$p; done