chiark / gitweb /
* Change my email address in the Maintainer field so that
[chiark-utils.git] / debian / rules
index 39826a257e786f72ce9024a14265542d5ed782b3..7ac91e218d491536c56eb651c445001d5c09e5bc 100755 (executable)
@@ -76,7 +76,6 @@ binary-prep:
        install -d $t/chiark-really/usr/share/man/man8
        cd $t/chiark-utils-bin/usr/sbin && \
                mv really $t/chiark-really/usr/sbin/
-       strip --strip-unneeded --remove-section .note --remove-section .comment $t/chiark-really/usr/sbin/really
        cd $t/chiark-utils-bin/usr/share/man/man8 && \
                mv really.8 $t/chiark-really/usr/share/man/man8/
        rm      $t/chiark-utils-bin/usr/sbin/trivsoundd \
@@ -111,6 +110,8 @@ binary-indep:       checkroot build binary-prep
 
 binary-arch:   checkroot build binary-prep
        $(checkdir)
+       set -ex; for p in chiark-really chiark-utils-bin chiark-rwbuffer; do \
+               dh_strip -p$$p -Pdebian/tmp/$$p; done
        dpkg-shlibdeps -Tdebian/sv-chiark-rwbuffer \
                $t/chiark-rwbuffer/usr/bin/*
        dpkg-shlibdeps -Tdebian/sv-chiark-really \
@@ -124,12 +125,12 @@ binary-arch:      checkroot build binary-prep
                a="$$a -d$$d $$f"; \
            done; set -x; \
            dpkg-shlibdeps -Tdebian/sv-chiark-utils-bin $$a
-       perl -i~ -pe '                                          \
-               next unless m/^shlibs:/;                        \
-               s/$$/,/; s/=/=, /;                              \
-               s/, libgmp3(?:c2)?,/, libgmp3 | libgmp3c2,/;    \
-               s/=, /=/; s/,$$//;                              \
-               ' debian/sv-*[!~]
+       perl -i~ -pe '                                          '\
+        -e'    next unless m/^shlibs:/;                        '\
+        -e'    s/$$/,/; s/=/=, /;                              '\
+        -e'    s/, libgmp3(?:c2)?,/, libgmp3 | libgmp3c2,/;    '\
+        -e'    s/=, /=/; s/,$$//;                              '\
+                       debian/sv-*[!~]
        set -e; for p in $(packages_arch); \
                do debian/rules binary-one p=$$p; done