chiark / gitweb /
rules: Drop seddery for libgmp3c2 C++ ABI transition.
[chiark-utils.git] / debian / rules
index 62d84cfccfdc115b37bdda682985667e2c980c76..32f312912b87f42b97d5d3508ceb3bf1d451a772 100755 (executable)
@@ -13,9 +13,16 @@ cwd= $(shell pwd)
 d=     $(cwd)/debian
 t=     $d/tmp
 
+makebuildargs := OPTIMISE= DEBUG= \
+ CMDLINE_CFLAGS="$(shell dpkg-buildflags --get CFLAGS)" \
+ CMDLINE_CPPFLAGS="$(shell dpkg-buildflags --get CPPFLAGS)" \
+ CMDLINE_LDFLAGS="$(shell dpkg-buildflags --get LDFLAGS)"
+
 build:
        $(checkdir)
-       set -e; for s in $(subdirs_build_arch); do $(MAKE) -C $$s all; done
+       set -e; for s in $(subdirs_build_arch); do \
+               $(MAKE) -C $$s all $(makebuildargs); \
+       done
        touch build
 
 build-indep: build
@@ -56,7 +63,7 @@ binary-prep:
                        $t/$$p/usr/share/doc/$$p/; \
                ln -s changelog.gz \
                        $t/$$p/usr/share/doc/$$p/changelog.Debian.gz; \
-               gzip -9v $t/$$p/usr/share/doc/$$p/changelog; \
+               gzip -9vn $t/$$p/usr/share/doc/$$p/changelog; \
                done
        #
        install -d $t/chiark-rwbuffer/usr/bin
@@ -84,10 +91,9 @@ binary-prep:
                mv really.8 $t/chiark-really/usr/share/man/man8/
        rm      $t/chiark-utils-bin/usr/sbin/trivsoundd \
                $t/chiark-utils-bin/usr/share/man/man8/trivsoundd.8
-       rmdir   $t/chiark-utils-bin/usr/sbin \
-               $t/chiark-utils-bin/usr/share/man/man8
+       rmdir   $t/chiark-utils-bin/usr/sbin
        #
-       gzip -9f $t/*/usr/share/man/man*/*
+       gzip -9fn $t/*/usr/share/man/man*/*
 
 binary-hook-chiark-backup:
 binary-hook-chiark-rwbuffer:
@@ -103,7 +109,7 @@ binary-one:
                chmod u=rwX,go=rX $t/$p/DEBIAN/$$f; \
        done
        dh_link -p$p -Pdebian/tmp/$p
-       dpkg-gencontrol -isp -p$p -P$t/$p -Tdebian/sv-$p
+       dpkg-gencontrol -p$p -P$t/$p -Tdebian/sv-$p
        chown -R root.root debian/tmp
        chmod -R g-ws debian/tmp
        debian/rules binary-hook-$p
@@ -123,19 +129,15 @@ binary-arch:      checkroot build binary-prep
                $t/chiark-really/usr/sbin/*
        set -e; for f in $t/chiark-utils-bin/usr/bin/*; do \
                case "$$f" in \
-               */xbatmon-simple)       d=Suggests      ;; \
-               */watershed|*/summer)   d=Recommends    ;; \
+               */xbatmon-simple|*/xduplic-copier) \
+                                       d=Suggests      ;; \
+               */watershed|*/summer|*/cgi-fcgi-interp) \
+                                       d=Recommends    ;; \
                *)                      d=Depends       ;; \
                esac; \
                a="$$a -d$$d $$f"; \
            done; set -x; \
            dpkg-shlibdeps -Tdebian/sv-chiark-utils-bin $$a
-       perl -i~ -pe '                                          '\
-        -e'    next unless m/^shlibs:/;                        '\
-        -e'    s/$$/,/; s/=/=, /;                              '\
-        -e'    s/, libgmp3(?:c2)?,/, libgmp3 | libgmp3c2,/;    '\
-        -e'    s/=, /=/; s/,$$//;                              '\
-                       debian/sv-*[!~]
        set -e; for p in $(packages_arch); \
                do debian/rules binary-one p=$$p; done