chiark / gitweb /
add with-lock-ex to new chiark-utils-bin package
[chiark-utils.git] / debian / rules
index 2b07399eabe0e7ca447e1b3c4a13026bbf38f1c2..13d0680e828b8d6b9d8378c5b1bf058cdfee7a7d 100755 (executable)
@@ -4,7 +4,7 @@ subdirs_build=  cprogs
 subdirs_nobuild=backup sync-accounts scripts
 package=       chiark-utils
 packages_indep=        chiark-backup chiark-scripts
-packages_arch= chiark-rwbuffer chiark-really
+packages_arch= chiark-rwbuffer chiark-really chiark-utils-bin
 packages=      $(packages_indep) $(packages_arch)
 
 cwd=   $(shell pwd)
@@ -37,6 +37,8 @@ binary-prep:
                        mandir=$t/$$s/usr/share/man; \
        done
        #
+       mv $t/cprogs $t/chiark-utils-bin
+       #
        cp -a debian/tmp/sync-accounts/* debian/tmp/scripts/.
        rm -r debian/tmp/sync-accounts
        mv debian/tmp/scripts debian/tmp/chiark-scripts
@@ -53,17 +55,22 @@ binary-prep:
        #
        install -d $t/chiark-rwbuffer/usr/bin
        install -d $t/chiark-rwbuffer/usr/share/man/man1
-       cd $t/cprogs/usr/bin && \
+       cd $t/chiark-utils-bin/usr/bin && \
                mv readbuffer writebuffer $t/chiark-rwbuffer/usr/bin/
-       cd $t/cprogs/usr/share/man/man1 && \
+       cd $t/chiark-utils-bin/usr/share/man/man1 && \
                mv readbuffer.1 writebuffer.1 $t/chiark-rwbuffer/usr/share/man/man1/
        #
        install -d $t/chiark-really/usr/sbin
        install -d $t/chiark-really/usr/share/man/man8
-       cd $t/cprogs/usr/sbin && \
+       cd $t/chiark-utils-bin/usr/sbin && \
                mv really $t/chiark-really/usr/sbin/
-#      cd $t/cprogs/usr/share/man/man8 && \
-#              mv really.8 $t/chiark-really/usr/share/man/man8/
+       strip --strip-unneeded $t/chiark-really/usr/sbin/really
+       cd $t/chiark-utils-bin/usr/share/man/man8 && \
+               mv really.8 $t/chiark-really/usr/share/man/man8/
+       rm      $t/chiark-utils-bin/usr/sbin/trivsoundd \
+               $t/chiark-utils-bin/usr/share/man/man8/trivsoundd.8
+       rmdir   $t/chiark-utils-bin/usr/sbin \
+               $t/chiark-utils-bin/usr/share/man/man8
        #
        gzip -9f $t/*/usr/share/man/man*/*
 
@@ -72,6 +79,7 @@ binary-hook-chiark-rwbuffer:
 binary-hook-sync-accounts:
 binary-hook-chiark-scripts:
 binary-hook-chiark-really:
+binary-hook-chiark-utils-bin:
 
 binary-one:
        set -e; for f in preinst postinst prerm postrm conffiles; do \
@@ -91,7 +99,12 @@ binary-indep:        checkroot build binary-prep
 
 binary-arch:   checkroot build binary-prep
        $(checkdir)
-       dpkg-shlibdeps -Tdebian/sv-chiark-rwbuffer $t/chiark-rwbuffer/usr/bin/*
+       dpkg-shlibdeps -Tdebian/sv-chiark-rwbuffer \
+               $t/chiark-rwbuffer/usr/bin/*
+       dpkg-shlibdeps -Tdebian/sv-chiark-really \
+               $t/chiark-really/usr/sbin/*
+       dpkg-shlibdeps -Tdebian/sv-chiark-utils-bin \
+               $t/chiark-utils-bin/usr/bin/*
        set -e; for p in $(packages_arch); \
                do debian/rules binary-one p=$$p; done