chiark / gitweb /
changelog entry for bashism fix
[chiark-utils.git] / cprogs / Makefile
index dbfad383c34f918c14b97ecd197eecd7ca4d2f40..01f375d0e5070606bac63414e020587ae28af5d5 100644 (file)
@@ -26,7 +26,7 @@ include ../settings.make
 RWBUFFER_SIZE_MB=16
 
 PROGRAMS=              readbuffer writebuffer with-lock-ex xacpi-simple \
-                       summer
+                       summer watershed
 SUIDSBINPROGRAMS=      really
 DAEMONS=               trivsoundd
 MAN1PAGES=             readbuffer.1 writebuffer.1 with-lock-ex.1
@@ -48,7 +48,10 @@ xacpi-simple:        xacpi-simple.o
                $(CC) -o $@ $< -L/usr/X11R6/lib -lX11 -lm
 
 summer:                summer.o
-               $(CC) -o $@ $< -lnettle
+               $(CC) -o $@ $< -lnettle -lgmp
+
+watershed:     watershed.o
+               $(CC) -o $@ $< -lnettle -lgmp
 
 install:               all
                $(INSTALL_DIRECTORY) $(bindir) $(sbindir)