chiark / gitweb /
autopkgtests: Select only tcl versions in unstable
authorIan Jackson <ijackson@chiark.greenend.org.uk>
Sat, 18 Aug 2018 22:56:47 +0000 (23:56 +0100)
committerIan Jackson <ijackson@chiark.greenend.org.uk>
Sat, 18 Aug 2018 23:20:06 +0000 (00:20 +0100)
autopkgtest in stretch bombs out on unsatisfiable test-dependencies.

This is better in sid with the skip-not-installable restriction.  [1]
and #905311, but that is very new and I don't want to use it here.

[1]
 https://salsa.debian.org/ci-team/autopkgtest/commit/7bf54dc669181f19671e01c691d2bf0321016a11

Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
debian/rules

index 464159c..f065f68 100755 (executable)
@@ -26,7 +26,7 @@ docdir=usr/share/doc/$(docpackage)
 tclh:=$(firstword $(wildcard /usr/include/tcl8.*/tcl.h))
 tclversion:=$(patsubst /usr/include/tcl%/tcl.h,%,$(tclh))
 
-tcl_versions= 8.4 8.5 8.6 8.7 8.8
+tcl_versions= 8.5 8.6 8.7
 
 march := $(shell dpkg-architecture -q DEB_HOST_MULTIARCH)
 libsubdir = /$(march)