chiark / gitweb /
Multiarch: Move .so's to triplet paths, and declare M-A: same.
[chiark-tcl.git] / debian / rules
index 323a3f37535646472035b34a94a172f689f0e39b..f9ed503fb1637fdfe7b2cf0b3016607821366f5c 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 
 # chiark-tcl - various Tcl bindings and extensions
-# Copyright 2006 Ian Jackson
+# Copyright 2006-2012 Ian Jackson
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License as
@@ -14,9 +14,7 @@
 # General Public License for more details.
 #
 # You should have received a copy of the GNU General Public License
-# along with this library; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
-# 02110-1301, USA.
+# along with this library; if not, see <http://www.gnu.org/licenses/>.
 
 
 majversion=1
@@ -25,13 +23,30 @@ libpackage=libtcl-chiark-$(majversion)
 docpackage=libtcl-chiark-$(majversion)
 docdir=usr/share/doc/$(docpackage)
 
+tclh:=$(firstword $(wildcard /usr/include/tcl8.*/tcl.h))
+tclversion:=$(patsubst /usr/include/tcl%/tcl.h,%,$(tclh))
+
+garch := $(shell dpkg-architecture -q DEB_HOST_GNU_TYPE)
+ifneq ($(garch),)
+
+libsubdir = /$(garch)
+
+ifeq ($(origin CC),default)
+export CC=$(garch)-gcc
+endif
+
+endif # $garch
+
 define checkdir
        test -f hbytes/hbytes.tct
 endef
 
-build:
+build: build-arch build-indep
+build-arch:
        $(checkdir)
-       $(MAKE) prefix=/usr VERSION=$(majversion)
+       $(MAKE) prefix=/usr VERSION=$(majversion) TCL_VERSION=$(tclversion)
+
+build-indep:
 
 clean:
        $(checkdir)
@@ -44,16 +59,16 @@ binary-indep:
 binary-arch:   checkroot build
        $(checkdir)
        -rm -rf debian/$(docpackage) debian/$(libpackage)
-       install -d debian/$(libpackage)/usr/lib
+       install -d debian/$(libpackage)/usr/lib$(libsubdir)
        install -d debian/$(docpackage)/usr/share/doc/$(docpackage)
 
-       set -e; for f in lintian linda; do                                   \
+       set -e; for f in lintian; do                                         \
                install -d debian/$(libpackage)/usr/share/$$f/overrides;     \
                cp debian/$$f-overrides                                      \
                 debian/$(libpackage)/usr/share/$$f/overrides/$(libpackage); \
                done
 
-       cp */*.so debian/$(libpackage)/usr/lib/.
+       cp */*.so debian/$(libpackage)/usr/lib$(libsubdir)/.
 
        set -e; for f in */*.[ch]; do                                   \
                perl debian/extractdoc <$$f                             \
@@ -65,12 +80,14 @@ binary-arch:        checkroot build
        dh_installchangelogs
        dh_strip
 
+       dh_makeshlibs
        dh_shlibdeps -Xchiark_tcl_adns -Xchiark_tcl_crypto
 
        # be consistent about what we compress:
        dh_compress -X.c.txt -X.h.txt
 
        dh_fixperms
+       dh_installdeb
        dh_gencontrol
        dh_md5sums
        dh_builddeb