chiark / gitweb /
tcmdifgen: Replace deprecated `use IO;' with `use IO::File'.
[chiark-tcl.git] / debian / rules
index 42e8bbe734ab156db22dfedfee0674f0a821d6d6..3675728eee9fcb4459de8b2e73df4b19a7bd9e8d 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 
 # chiark-tcl - various Tcl bindings and extensions
-# Copyright 2006 Ian Jackson
+# Copyright 2006-2012 Ian Jackson
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License as
@@ -14,9 +14,7 @@
 # General Public License for more details.
 #
 # You should have received a copy of the GNU General Public License
-# along with this library; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
-# 02110-1301, USA.
+# along with this library; if not, see <http://www.gnu.org/licenses/>.
 
 
 majversion=1
@@ -25,13 +23,31 @@ libpackage=libtcl-chiark-$(majversion)
 docpackage=libtcl-chiark-$(majversion)
 docdir=usr/share/doc/$(docpackage)
 
+tclh:=$(firstword $(wildcard /usr/include/tcl8.*/tcl.h))
+tclversion:=$(patsubst /usr/include/tcl%/tcl.h,%,$(tclh))
+
+march := $(shell dpkg-architecture -q DEB_HOST_MULTIARCH)
+libsubdir = /$(march)
+
+garch := $(shell dpkg-architecture -q DEB_HOST_GNU_TYPE)
+ifneq ($(garch),)
+
+ifeq ($(origin CC),default)
+export CC=$(garch)-gcc
+endif
+
+endif # $garch
+
 define checkdir
        test -f hbytes/hbytes.tct
 endef
 
-build:
+build: build-arch build-indep
+build-arch:
        $(checkdir)
-       $(MAKE) prefix=/usr VERSION=$(majversion)
+       $(MAKE) prefix=/usr VERSION=$(majversion) TCL_VERSION=$(tclversion)
+
+build-indep:
 
 clean:
        $(checkdir)
@@ -44,10 +60,16 @@ binary-indep:
 binary-arch:   checkroot build
        $(checkdir)
        -rm -rf debian/$(docpackage) debian/$(libpackage)
-       install -d debian/$(libpackage)/usr/lib
+       install -d debian/$(libpackage)/usr/lib$(libsubdir)
        install -d debian/$(docpackage)/usr/share/doc/$(docpackage)
 
-       cp */*.so debian/$(libpackage)/usr/lib/.
+       set -e; for f in lintian; do                                         \
+               install -d debian/$(libpackage)/usr/share/$$f/overrides;     \
+               cp debian/$$f-overrides                                      \
+                debian/$(libpackage)/usr/share/$$f/overrides/$(libpackage); \
+               done
+
+       cp */*.so debian/$(libpackage)/usr/lib$(libsubdir)/.
 
        set -e; for f in */*.[ch]; do                                   \
                perl debian/extractdoc <$$f                             \
@@ -59,12 +81,14 @@ binary-arch:        checkroot build
        dh_installchangelogs
        dh_strip
 
-       dh_shlibdeps
+       dh_makeshlibs
+       dh_shlibdeps -Xchiark_tcl_adns -Xchiark_tcl_crypto
 
        # be consistent about what we compress:
-       dh_compress -X'*.[ch].txt'
+       dh_compress -X.c.txt -X.h.txt
 
        dh_fixperms
+       dh_installdeb
        dh_gencontrol
        dh_md5sums
        dh_builddeb