chiark / gitweb /
fix spelling of defence in changelog
[chiark-tcl.git] / debian / rules
index c3e4eeed108e0d2766ea63bac1298623f2f258a1..013cf5230fd4f546790e601a66fb836d43db27dd 100755 (executable)
@@ -25,13 +25,16 @@ libpackage=libtcl-chiark-$(majversion)
 docpackage=libtcl-chiark-$(majversion)
 docdir=usr/share/doc/$(docpackage)
 
+tclh:=$(firstword $(wildcard /usr/include/tcl8.*/tcl.h))
+tclversion:=$(patsubst /usr/include/tcl%/tcl.h,%,$(tclh))
+
 define checkdir
        test -f hbytes/hbytes.tct
 endef
 
 build:
        $(checkdir)
-       $(MAKE) prefix=/usr VERSION=$(majversion)
+       $(MAKE) prefix=/usr VERSION=$(majversion) TCL_VERSION=$(tclversion)
 
 clean:
        $(checkdir)
@@ -65,10 +68,10 @@ binary-arch:        checkroot build
        dh_installchangelogs
        dh_strip
 
-       dh_shlibdeps
+       dh_shlibdeps -Xchiark_tcl_adns -Xchiark_tcl_crypto
 
        # be consistent about what we compress:
-       dh_compress -X'*.[ch].txt'
+       dh_compress -X.c.txt -X.h.txt
 
        dh_fixperms
        dh_gencontrol