chiark / gitweb /
Add a few assertions about *_LLEN in adns.c.
[chiark-tcl.git] / debian / rules
index 323a3f37535646472035b34a94a172f689f0e39b..013cf5230fd4f546790e601a66fb836d43db27dd 100755 (executable)
@@ -25,13 +25,16 @@ libpackage=libtcl-chiark-$(majversion)
 docpackage=libtcl-chiark-$(majversion)
 docdir=usr/share/doc/$(docpackage)
 
+tclh:=$(firstword $(wildcard /usr/include/tcl8.*/tcl.h))
+tclversion:=$(patsubst /usr/include/tcl%/tcl.h,%,$(tclh))
+
 define checkdir
        test -f hbytes/hbytes.tct
 endef
 
 build:
        $(checkdir)
-       $(MAKE) prefix=/usr VERSION=$(majversion)
+       $(MAKE) prefix=/usr VERSION=$(majversion) TCL_VERSION=$(tclversion)
 
 clean:
        $(checkdir)