chiark / gitweb /
@@ -1,4 +1,4 @@
[chiark-tcl.git] / debian / changelog
index 418d5e719af9bc164f769b5af0d52bf6d9b747ce..e57556ccab4ceb5641c748ff75502f5e84854068 100644 (file)
@@ -1,30 +1,56 @@
-chiark-tcl (1.0.1) unstable; urgency=low
+chiark-tcl (1.0.2~~iwj) unstable; urgency=low
 
-  * dgram: New extension for datagram sockets; dgram-socket command.
-  * New way of doing toplevels with tcmdifgen dispatch() primitive.
-  * Replace #include <tcl8.3/tcl.h> with <tcl.h> and in build system find
-    Tcl version and pass appropriate -I option.  (Closes: #362806.)
-  * Declare versioned build-dependency on libadns1-dev >= 1.2
-    since we need adns_init_logfn.  (Closes: #382287.)
+  New features:
+  * hbcrypto hash-{init,update,final} etc. for incremental hashing.
 
- --
+  Bugfixes:
+  * Do not adns_cancel in the middle of adns_forallqueries.
+  * cdb: When cdbwr update writerecord fails, try to recover the
+    situation to sanity so we don't corrupt the log later; if this
+    fails, mark the cdb broken.
+  * strlen returns size_t, not int; fixed up everywhere relevant.
+    Closes #393970.  (Bug exists only where int and ssize_t differ.)
+  * Use correct errno value for error writing to new .main during compact.
+  * Do not coredump if fclose journal fails during compact.
+  * Do not fail lookups on cdb-wr's opened from just-created dbs.
+  * Do not leak cdb innards on compact.
 
-chiark-tcl (1.0.0.99.iwj.2) unstable; urgency=low
+  Portability fixes:
+  * Remove unecessary assertion of val<=0xffffffffUL where uint32_t val;
+    Closes: #394039 (FTBFS due to unhelpful GCC warning).
 
-  * Provide adns txt RRs.
+  Internal improvements:
+  * Add a few assertions about *_LLEN in adns.c.
+  * Comprehensive review of use of `int' and defence against overflow.
 
- -- Ian Jackson <ian@localhost.localdomain>  Mon,  3 Apr 2006 02:12:43 +0100
+ -- Ian Jackson <ian@davenant.greenend.org.uk>  Sun, 25 Mar 2007 20:13:20 +0100
 
-chiark-tcl (1.0.0.99.iwj.1) unstable; urgency=low
+chiark-tcl (1.0.1) unstable; urgency=low
 
+  New features:
+  * adns: Provide txt RRs.
+  * dgram: New extension for datagram sockets; dgram-socket command.
+  * tuntap: New extension for tun/tap interfaces (currently, tun only).
+
+  Documentation, build and packaging fixes:
+  * Correct doc comment for supplying query options to adns asynch.
+  * Replace #include <tcl8.3/tcl.h> with <tcl.h> and in build system find
+    Tcl version and pass appropriate -I option.  Closes: #362806.
+  * Declare versioned build-dependency on libadns1-dev >= 1.2
+    since we need adns_init_logfn.  Closes: #382287.
+  * Declare build-dependency on libcdb-dev | tinycdb (<= 0.75)
+    since cdb.h etc. is in libcdb-dev off nowadays.  Closes: #387904.
+  * Pass -Wno-strict-aliasing.  The compiler is wrong.
   * Do not run dpkg-shlibdeps on adns and nettle plugins.
     This prevents them turning up in Depends - see the README.
   * Use correct syntax for avoiding compressing doc/*/*.[ch].txt.
   * Use correct variable name for cht_adnstcl_{queries,resolvers}
     everywhere (prevents coredump accessing uninitialised version).
-  * Correct doc comment for supplying query options to adns asynch.
+  
+  Internal changes:
+  * New way of doing toplevels with tcmdifgen dispatch() primitive.
 
- -- Ian Jackson <ian@localhost.localdomain>  Mon,  3 Apr 2006 01:53:33 +0100
+ -- Ian Jackson <ian@davenant.greenend.org.uk>  Wed, 18 Oct 2006 17:05:03 +0100
 
 chiark-tcl (1.0.0) unstable; urgency=low