chiark / gitweb /
Makefiles: Refer to $(BASE_DIR) rather than ../base/
[chiark-tcl.git] / debian / changelog
index e8b7534e84e7a3c6ea68f577619f579c58564d79..81af3786333e469bd2561541fba87a5a29d276d2 100644 (file)
@@ -1,12 +1,94 @@
-chiark-tcl (1.1.1~~iwj) unstable; urgency=low
+chiark-tcl (1.2.2~) unstable; urgency=medium
 
-  * Add ${misc:Depends} to Depends field (should not currently have
-    any effect on the binary package).
+  tcmdifgen:
+  * Turn on warnings and `use strict' and fix everything.
+  * Replace deprecated `use IO;' with `use IO::File'.
+
+  Makefiles:
+  * Refer to $(BASE_DIR) rather than ../base/, making out-of-tree
+    extentions a bit easier.
+
+ --
+
+chiark-tcl (1.2.1) unstable; urgency=high
+
+  * Multiarch: Use correct M-A triplet (DEB_HOST_MULTIARCH) for
+    libsubdir.  Closes:#856526.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 19 Mar 2017 09:22:48 +0000
+
+chiark-tcl (1.2.0) unstable; urgency=medium
+
+  * wiringpi module.  Built only if the wiringpi headers are actually
+    installed (so not in the official Debian release).
+  * Update .gitignore for recent debhelper droppings.
+  * Do not build tuntap on non-Linux platforms.  Ideally this would
+    be replaced with similar functionality elsewhere, but for now
+    this change fixes the FTBFS on Debian hurd-* and kfreebsd-*.
+  * Update build-dependencies to permit tcl8.6.  Closes:#818475.
+  * Replace ad-hocery with use of offsetof/typeof.  Closes:#812718.
+  * Honour dpkg-architecture's DEB_HOST_GNU_TYPE, to fix cross-building.
+  * Multiarch: Move .so's to triplet paths, and declare M-A: same.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Tue, 24 Jan 2017 14:32:11 +0000
+
+chiark-tcl (1.1.3) unstable; urgency=low
+
+  * Build-Depends: Add tcl8.5-dev to the front of the list of
+    possibilities.  Current Tcl packages do not provide tcl-dev, and no
+    earlier version than 8.5 is, in fact, in jessie (8.4 was removed in
+    April 2014).  Closes:#775635.  (FTBFS)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Thu, 22 Jan 2015 19:00:22 +0000
+
+chiark-tcl (1.1.2) unstable; urgency=low
+
+  * tuntap: Use <net/if.h> not <linux/if.h>.  Closes:#768766.  (FTBFS)
+  * Build-Depends: move tcl-dev to the end, so that we prefer tcl8.4-dev.
+    This is necessary because we want to build against tcl8.4 in jessie
+    to avoid requiring a newer Tcl ABI.
+  * Reintroduce .gitignore which a build tool brokenly deleted.
+  * Remove .cvsignore files from git repo.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 09 Nov 2014 12:44:18 +0000
+
+chiark-tcl (1.1.1+nmu1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * Build against the default Tcl version instead of deprecated 8.4
+    (closes: #725248).
+
+ -- Sergei Golovan <sgolovan@debian.org>  Tue, 15 Oct 2013 21:12:46 +0400
+
+chiark-tcl (1.1.1) unstable; urgency=low
+
+  Bugfix:
+  * Handling of errors reading /dev/urandom fixed.
+
+  User-visible change:
+  * Mention dgram, tuntap and maskmap in Description.  Fix typo.
+
+  Build improvements:
+  * Fix FTBFS in sid due to warning from recent versions of gcc
+    about set but not used variables.
+  * Update default TCL_VERSION for upstream build to 8.4.
+
+  Packaging improvements:
+  * Remove the pointless copyright notice from the end of the changelog.
+  * Add ${misc:Depends} to Depends field (has no effect on the .deb).
   * Provide build-arch and build-indep targets.
+  * Suppress lintian warning about package-name-doesnt-match-sonames.
+  * Remove lintian override for non-PIC cdb, due to tinycdb not having
+    PIC code in it.  This is now fixed in libcdb-dev.
   * Remove linda overrides.
+  * Add a .gitignore.
+  * Update debian/compat to 5.  No changes needed.
+  * Update Standards-Version.  No changes needed.
+  * Update Copyright dates.
+  * Remove FSF street address from copyright notices.
   * Change my email address.
 
- -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 02 Jun 2012 11:29:10 +0100
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 02 Jun 2012 14:20:35 +0100
 
 chiark-tcl (1.1.0+nmu2) unstable; urgency=low
 
@@ -89,22 +171,3 @@ chiark-tcl (1.0.0) unstable; urgency=low
     (of which cdb and adns will be needed for new SAUCE).
 
  -- Ian Jackson <ian@davenant.greenend.org.uk>  Thu, 30 Mar 2006 18:34:51 +0100
-
-
-# chiark-tcl - various Tcl bindings and extensions
-# Copyright 2006 Ian Jackson
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2 of the
-# License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this library; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
-# 02110-1301, USA.