chiark / gitweb /
use of int and overflow review
[chiark-tcl.git] / debian / changelog
index bbf511e34535f510add525ad7be3dbeb51d59a90..64d09f77d19fde495e5173d9c9eb7c8879145104 100644 (file)
@@ -2,9 +2,16 @@ chiark-tcl (1.0.2) unstable; urgency=low
 
   Bugfixes:
   * Do not adns_cancel in the middle of adns_forallqueries.
+  * strlen returns size_t, not int; fixed up everywhere relevant.
+    Closes #393970.  (Bug exists only where int and ssize_t differ.)
+
+  Portability fixes:
+  * Remove unecessary assertion of val<=0xffffffffUL where uint32_t val;
+    Closes: #394039 (FTBFS due to unhelpful GCC warning).
 
   Internal improvements:
   * Add a few assertions about *_LLEN in adns.c.
+  * Comprehensive review of use of `int' and defense against overflow.
 
  --