chiark / gitweb /
use of int and overflow review
[chiark-tcl.git] / debian / changelog
index 569227a8a899c67db1424d276fd7264456a41270..64d09f77d19fde495e5173d9c9eb7c8879145104 100644 (file)
@@ -1,3 +1,20 @@
+chiark-tcl (1.0.2) unstable; urgency=low
+
+  Bugfixes:
+  * Do not adns_cancel in the middle of adns_forallqueries.
+  * strlen returns size_t, not int; fixed up everywhere relevant.
+    Closes #393970.  (Bug exists only where int and ssize_t differ.)
+
+  Portability fixes:
+  * Remove unecessary assertion of val<=0xffffffffUL where uint32_t val;
+    Closes: #394039 (FTBFS due to unhelpful GCC warning).
+
+  Internal improvements:
+  * Add a few assertions about *_LLEN in adns.c.
+  * Comprehensive review of use of `int' and defense against overflow.
+
+ --
+
 chiark-tcl (1.0.1) unstable; urgency=low
 
   New features: