chiark / gitweb /
finalise changelog again
[chiark-tcl.git] / debian / changelog
index 6b91a92e3b1b0bde223534435aa77137f85dbf38..63c43b0782780fec86cbb95fd11dc65f64268dab 100644 (file)
+chiark-tcl (1.1.1) unstable; urgency=low
+
+  Bugfix:
+  * Handling of errors reading /dev/urandom fixed.
+
+  User-visible change:
+  * Mention dgram, tuntap and maskmap in Description.  Fix typo.
+
+  Build improvements:
+  * Fix FTBFS in sid due to warning from recent versions of gcc
+    about set but not used variables.
+  * Update default TCL_VERSION for upstream build to 8.4.
+
+  Packaging improvements:
+  * Remove the pointless copyright notice from the end of the changelog.
+  * Add ${misc:Depends} to Depends field (has no effect on the .deb).
+  * Provide build-arch and build-indep targets.
+  * Suppress lintian warning about package-name-doesnt-match-sonames.
+  * Remove lintian override for non-PIC cdb, due to tinycdb not having
+    PIC code in it.  This is now fixed in libcdb-dev.
+  * Remove linda overrides.
+  * Add a .gitignore.
+  * Update debian/compat to 5.  No changes needed.
+  * Update Standards-Version.  No changes needed.
+  * Update Copyright dates.
+  * Remove FSF street address from copyright notices.
+  * Change my email address.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sat, 02 Jun 2012 14:20:35 +0100
+
+chiark-tcl (1.1.0+nmu2) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * debian/rules: add invocation of dh_makeshlibs and dh_installdeb, so
+    that ldconfig is invoked in postinst (Closes: #553122)
+  * debian/control: replace libnettle-dev by nettle-dev (which replaces
+    the former) in build-dependencies
+
+ -- Stefano Zacchiroli <zack@debian.org>  Thu, 19 Nov 2009 09:09:57 +0100
+
+chiark-tcl (1.1.0+nmu1) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * Fix FTBFS with gcc-4.3 by adding <limits.h> include to
+    base/chiark-tcl.h as suggested by Michael Bienia (Closes: #489901).
+  * Set urgency to “medium” as this bug affects testing too.
+
+ -- Cyril Brulebois <kibi@debian.org>  Sun, 19 Jul 2009 18:23:54 +0200
+
+chiark-tcl (1.1.0) unstable; urgency=high
+
+  New features:
+  * hbcrypto hash-{init,update,final} etc. for incremental hashing.
+
+  Bugfixes:
+  * Do not adns_cancel in the middle of adns_forallqueries.
+  * cdb: When cdbwr update writerecord fails, try to recover the
+    situation to sanity so we don't corrupt the log later; if this
+    fails, mark the cdb broken.
+  * strlen returns size_t, not int; fixed up everywhere relevant.
+    Closes #393970.  (Bug exists only where int and ssize_t differ.)
+  * Use correct errno value for error writing to new .main during compact.
+  * Do not coredump if fclose journal fails during compact.
+  * Do not fail lookups on cdb-wr's opened from just-created dbs.
+  * Do not leak cdb innards on compact.
+
+  Portability fixes:
+  * Remove unecessary assertion of val<=0xffffffffUL where uint32_t val;
+    Closes: #394039 (FTBFS due to unhelpful GCC warning).
+  * Use -fno-strict-aliasing because gcc-4.3 apparently ignores
+    -Wno-strict-aliasing!  Closes: #471004.
+
+  Internal improvements:
+  * Add a few assertions about *_LLEN in adns.c.
+  * Comprehensive review of use of `int' and defence against overflow.
+
+ -- Ian Jackson <ian@davenant.greenend.org.uk>  Fri, 20 Jun 2008 22:50:25 +0100
+
 chiark-tcl (1.0.1) unstable; urgency=low
 
+  New features:
+  * adns: Provide txt RRs.
+  * dgram: New extension for datagram sockets; dgram-socket command.
+  * tuntap: New extension for tun/tap interfaces (currently, tun only).
+
+  Documentation, build and packaging fixes:
+  * Correct doc comment for supplying query options to adns asynch.
+  * Replace #include <tcl8.3/tcl.h> with <tcl.h> and in build system find
+    Tcl version and pass appropriate -I option.  Closes: #362806.
+  * Declare versioned build-dependency on libadns1-dev >= 1.2
+    since we need adns_init_logfn.  Closes: #382287.
+  * Declare build-dependency on libcdb-dev | tinycdb (<= 0.75)
+    since cdb.h etc. is in libcdb-dev off nowadays.  Closes: #387904.
+  * Pass -Wno-strict-aliasing.  The compiler is wrong.
   * Do not run dpkg-shlibdeps on adns and nettle plugins.
     This prevents them turning up in Depends - see the README.
   * Use correct syntax for avoiding compressing doc/*/*.[ch].txt.
+  * Use correct variable name for cht_adnstcl_{queries,resolvers}
+    everywhere (prevents coredump accessing uninitialised version).
+  
+  Internal changes:
+  * New way of doing toplevels with tcmdifgen dispatch() primitive.
 
- --
+ -- Ian Jackson <ian@davenant.greenend.org.uk>  Wed, 18 Oct 2006 17:05:03 +0100
 
 chiark-tcl (1.0.0) unstable; urgency=low
 
@@ -12,22 +109,3 @@ chiark-tcl (1.0.0) unstable; urgency=low
     (of which cdb and adns will be needed for new SAUCE).
 
  -- Ian Jackson <ian@davenant.greenend.org.uk>  Thu, 30 Mar 2006 18:34:51 +0100
-
-
-# chiark-tcl - various Tcl bindings and extensions
-# Copyright 2006 Ian Jackson
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2 of the
-# License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this library; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
-# 02110-1301, USA.