chiark / gitweb /
remove confusing version
authorIan Jackson <ijackson@chiark.greenend.org.uk>
Sun, 10 Jun 2012 21:50:26 +0000 (22:50 +0100)
committerIan Jackson <ijackson@chiark.greenend.org.uk>
Sun, 10 Jun 2012 21:50:26 +0000 (22:50 +0100)
authbind.c
debian/changelog

index 484f0e7..8dd8f0c 100644 (file)
@@ -30,8 +30,7 @@
 static void printusage(FILE *f) {
   if (fprintf(f,
              "usage:       authbind [<options>] <program> <arg> <arg> ...\n"
-             "options:     --deep    --depth <levels>\n"
-             "version:     " MAJOR_VER "." MINOR_VER "\n")
+             "options:     --deep    --depth <levels>\n")
       == EOF) { perror("printf usage"); exit(-1); }
 }
 
index d3c6b8c..5541055 100644 (file)
@@ -2,8 +2,12 @@ authbind (2.1.1) unstable; urgency=low
 
   * Manpage has an example of which files will be checked and read
     Closes: #676540.
+  * Do not include library version number in usage output from helper; the
+    library and package version numbers are not the same, so this is
+    misleading, and we do not want to introduce new machinery just to
+    plumb the package version number through.  Closes: #676440.
 
- --
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 10 Jun 2012 22:49:48 +0100
 
 authbind (2.1.0) unstable; urgency=low