chiark / gitweb /
fix changelog entry typo
[authbind.git] / debian / rules
index 6afca930584fe310f604539bc8657bac259f0d15..96d90aa2abc8cf827c1804cec0cec704eae4e6a5 100755 (executable)
@@ -21,6 +21,7 @@
 # $Id$
 
 CC= gcc
+SHELL=/bin/bash
 
 package=authbind
 major=1
@@ -43,6 +44,9 @@ LDFLAGS += -g
 
 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
 INSTALL_PROGRAM += -s
+STRIP=strip
+else
+STRIP=:
 endif
 
 export CFLAGS
@@ -52,6 +56,7 @@ export INSTALL_FILE
 export INSTALL_PROGRAM
 export INSTALL_SCRIPT
 export INSTALL_DIR
+export STRIP
 
 
 build: 
@@ -81,11 +86,6 @@ binary-arch: checkroot build
        gzip -9 debian/tmp/usr/share/man/man*/* $(udp)/*
        $(INSTALL_FILE) debian/copyright $(udp)/.
        $(INSTALL_SCRIPT) debian/{postrm,prerm,postinst} debian/tmp/DEBIAN
-ifneq ($(arch),alpha)
-       $(INSTALL_FILE) debian/shlibs debian/tmp/DEBIAN
-else
-       $(INSTALL_FILE) debian/shlibs.alpha debian/tmp/DEBIAN/shlibs
-endif
        dpkg-shlibdeps ./authbind
        dpkg-gencontrol -isp
        chown -R root.root debian/tmp