chiark / gitweb /
do not strip if DEB_BUILD_OPTIONS=nostrip
[authbind.git] / debian / rules
index f967ad31287b5a12cd947dfcb82ed5a44c163111..2e872bcdffec05ae2ef9f432e20259d0b74d655e 100755 (executable)
@@ -44,6 +44,9 @@ LDFLAGS += -g
 
 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
 INSTALL_PROGRAM += -s
+STRIP=strip
+else
+STRIP=:
 endif
 
 export CFLAGS
@@ -53,6 +56,7 @@ export INSTALL_FILE
 export INSTALL_PROGRAM
 export INSTALL_SCRIPT
 export INSTALL_DIR
+export STRIP
 
 
 build: