chiark / gitweb /
reuse quilt variables
[topgit.git] / debian / tg2quilt.mk
index d079e75a34636304a29bd520234aa29807f7f32e..9c597d2e8d38b8bc356a8da2a6dceb03124aa134 100644 (file)
@@ -5,8 +5,9 @@
 # a quilt series.
 #
 # It is intended to be included from debian/rules files of TopGit-using
-# packages, like so:
+# packages after including the quilt rules, like so:
 #
+#   include /usr/share/quilt/quilt.make
 #   -include /usr/share/topgit/tg2quilt.mk
 #
 # The snippet exports the following targets. These targets only perform the
 # The PATCHES_DIR variable can be set before including the file to override
 # the default debian/patches location.
 #
-# Copyright © 2008 martin f. krafft <madduck@debian.org>
-# Released under terms of the the Artistic Licence 2.0.
+# More information, particularly for people working on TopGit-using packages,
+# can be found in /usr/share/doc/topgit/HOWTO-tg2quilt.gz .
+#
+# Copyright © 2008 martin f. krafft <madduck@debian.org> Released under terms
+# of the the Artistic Licence 2.0.
 #
 
-ifeq ($(shell tg summary -t)),)
+ifeq ($(shell tg summary -t),)
   # This is not a TopGit branch, so just blubber a bit.
 
   tg-export tg-clean tg-forceclean tg-rmdir:
@@ -57,11 +61,11 @@ else
 
 # We are in a TopGit branch, so let the fun begin.
 
-PATCHES_DIR ?= debian/patches
+PATCHES_DIR ?= $(QUILT_PATCH_DIR)
 
 # Hook tg-export into quilt's make(1) snippet such that it gets executed
 # before quilt patches or unpatches.
-debian/stamp-patched: tg-export
+$(QUILT_STAMPFN): tg-export
 unpatch: __tg-temp-export
 __tg-temp-export:
        @echo "Exporting TopGit branches to series so that quilt can clean up..." >&2