chiark / gitweb /
Bump version to 7.0.1~iwj0
[chiark-utils.git] / debian / rules
index 4d93627f29b6b95149c7ea0802fa6f3c195df904..403c7285ddb84a93c5cdee77844b2f7ae8a3e2e9 100755 (executable)
@@ -3,7 +3,7 @@
 SHELL=/bin/bash
 
 subdirs_build_arch=    cprogs
-subdirs_nobuild=backup sync-accounts scripts
+subdirs_nobuild=backup sync-accounts scripts fishdescriptor
 package=       chiark-utils
 packages_indep=        chiark-backup chiark-scripts
 packages_arch= chiark-rwbuffer chiark-really chiark-utils-bin
@@ -21,7 +21,7 @@ makebuildargs := OPTIMISE= DEBUG= \
 build:
        $(checkdir)
        set -e; for s in $(subdirs_build_arch); do \
-               $(MAKE) -C $$s all $(makebuildargs); \
+               dh_auto_build --sourcedirectory=$$s -- all $(makebuildargs); \
        done
        touch build
 
@@ -52,6 +52,7 @@ binary-prep:
        #
        mv $t/cprogs $t/chiark-utils-bin
        #
+       cp -a debian/tmp/fishdescriptor/* debian/tmp/scripts/.
        cp -a debian/tmp/sync-accounts/* debian/tmp/scripts/.
        rm -r debian/tmp/sync-accounts
        mv debian/tmp/scripts debian/tmp/chiark-scripts
@@ -63,7 +64,7 @@ binary-prep:
                        $t/$$p/usr/share/doc/$$p/; \
                ln -s changelog.gz \
                        $t/$$p/usr/share/doc/$$p/changelog.Debian.gz; \
-               gzip -9v $t/$$p/usr/share/doc/$$p/changelog; \
+               gzip -9vn $t/$$p/usr/share/doc/$$p/changelog; \
                done
        #
        install -d $t/chiark-rwbuffer/usr/bin
@@ -93,7 +94,7 @@ binary-prep:
                $t/chiark-utils-bin/usr/share/man/man8/trivsoundd.8
        rmdir   $t/chiark-utils-bin/usr/sbin
        #
-       gzip -9f $t/*/usr/share/man/man*/*
+       gzip -9fn $t/*/usr/share/man/man*/*
 
 binary-hook-chiark-backup:
 binary-hook-chiark-rwbuffer:
@@ -108,6 +109,7 @@ binary-one:
                cp debian/$p/$$f $t/$p/DEBIAN/$$f; \
                chmod u=rwX,go=rX $t/$p/DEBIAN/$$f; \
        done
+       dh_lintian -p$p -Pdebian/tmp/$p
        dh_link -p$p -Pdebian/tmp/$p
        dpkg-gencontrol -p$p -P$t/$p -Tdebian/sv-$p
        chown -R root.root debian/tmp
@@ -131,18 +133,13 @@ binary-arch:      checkroot build binary-prep
                case "$$f" in \
                */xbatmon-simple|*/xduplic-copier) \
                                        d=Suggests      ;; \
-               */watershed|*/summer)   d=Recommends    ;; \
+               */watershed|*/summer|*/cgi-fcgi-interp|*/prefork-interp) \
+                                       d=Recommends    ;; \
                *)                      d=Depends       ;; \
                esac; \
                a="$$a -d$$d $$f"; \
            done; set -x; \
            dpkg-shlibdeps -Tdebian/sv-chiark-utils-bin $$a
-       perl -i~ -pe '                                          '\
-        -e'    next unless m/^shlibs:/;                        '\
-        -e'    s/$$/,/; s/=/=, /;                              '\
-        -e'    s/, libgmp3(?:c2)?,/, libgmp3 | libgmp3c2,/;    '\
-        -e'    s/=, /=/; s/,$$//;                              '\
-                       debian/sv-*[!~]
        set -e; for p in $(packages_arch); \
                do debian/rules binary-one p=$$p; done