chiark / gitweb /
fix detection of topgit repo
[topgit.git] / debian / README.source
index 3d069576b2d3ea394068332d6f7c6186335a2242..7ae068f179dfb8c8ab30719d79b4eceb64c4b075 100644 (file)
@@ -18,7 +18,11 @@ Cloning a TopGit repository requires an additional step to normal Git cloning:
 2. cd topgit
 3. tg remote --populate origin
 
-TODO: debcheckout support
+You can also use the debcheckout tool from the devscripts package:
+
+  debcheckout topgit
+
+which will do all the above for you automatically.
 
 Branches in use
 '''''''''''''''
@@ -70,11 +74,12 @@ the top of debian/rules:
 This will provide the tg-export target, which will create a quilt series of
 all TopGit branches in the current repository.
 
-You can also set the variable TG_BRANCHES to a space- or comma-separated list
-(but not comma and space) of feature branches to export, e.g.:
+You can also set the variable TG_BRANCHES before the inclusion to a space- or
+comma-separated list (but not comma and space) of feature branches to export,
+e.g.:
 
-  TG_BRANCH := branch1,branch2
-  TG_BRANCH := 'branch3 branch4 branch 5'
+  TG_BRANCHES := branch1,branch2
+  TG_BRANCHES := 'branch3 branch4 branch 5'
 
 (The TopGit package actually uses the local version of the file)