PuTTY bug xp-wont-run

Home | Licence | FAQ | Docs | Download | Keys | Links
Mirrors | Updates | Feedback | Changes | Wishlist | Team

summary: Fails to run on some versions of Windows XP
class: bug: This is clearly an actual problem we want fixed.
difficulty: fun: Just needs tuits, and not many of them.
priority: high: This should be fixed in the next release.
absent-in: 0.57
present-in: 0.58
fixed-in: 2005-04-07 r5604 (0.59) (0.60) (0.61) (0.62) (0.63) (0.64) (0.65) (0.66) (0.67)

PuTTY 0.58 utterly fails to run on some (but not all) versions of Windows XP, with the following error message:

The application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.

or (in German):

Diese Anwendung konnte nicht gestartet werden, weil die Anwenungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren.
(the word 'Anwenungskonfiguration' is apparently a misspelling which occurs in the original error message; it should apparently be 'Anwendungskonfiguration'.)

or (in Dutch):

De toepassing kan niet worden gestart omdat de configuratie van de toepassing onjuist is. Het opnieuw installeren van de toepassing kan die probleem oplossen.

or (in Portuguese):

Falha na inicialização do aplicativo devido a configuração incorreta. A reinstalação do aplicativo pode resolver o problema.

(Reinstalling PuTTY does not fix the problem.)

As far as we can tell, this problem only affects Windows XP systems that don't have Service Pack 2 installed. In particular, we've had reports that installing SP2 solves the problem.

This is due to a trim I (JTN) made to the application manifests; the trimmed version conformed to Microsoft's specifications, and we tested it on one XP install (SP1), but it seems not all XP installs are born equal in this regard.

It affects only the graphical utilities (PuTTY, PuTTYtel, PuTTYgen, and Pageant).

If you run into this, we recommend upgrading to PuTTY 0.59 or later, which do not suffer from this problem.

If you really must use 0.58, you can still fix the problem with a separate manifest file. If you download the following files, rename them as indicated, and put them in the same directory as the relevant 0.58 executable, they should override the application manifests and allow them to run.


If you want to comment on this web site, see the Feedback page.
Audit trail for this bug.
(last revision of this bug record was at 2008-02-10 14:42:39 +0000)